Help, Traktor Pro, HUGE CPU spikes!!!
Results 1 to 7 of 7
  1. #1

    Default Help, Traktor Pro, HUGE CPU spikes!!!

    Hey,

    I am having some issues I was hoping someone might have some answers.
    I was having an issue with traktor crashing while It was closing down. due to windows having an error and blue screening with error messages and restarting once while I was shutting traktor down. It had not worked properly since. I was using Vista as Numark had not released drivers for win7 for my DJ I/O.
    So in light of doing a full reinstall, I decided to upgrade my Vista partition which had Traktor on it only. ( I use my Win7 partition for general use)
    I upgraded the partition to Win7 and installed Traktor 1.2.4 to it.
    It is the only program on the drive. It worked fine until I had rebooted the partition the next day.

    Then everytime I load a track into traktor the cpu spikes to 100%, audio virtually stops and sounds awful and the whole program freezes for up to 10 seconds.
    I find this strange as Traktor had worked brilliantly with vista.
    I am using a Numark stealth control, Numark DJ I/O with Win7 drivers, and a fujitsu siemens Amilo with 1.76 GHz processor, and 2GB of RAM.
    When using Traktor it is always the only program running in the drive and I have maximised Win7 for maximum performance, yet each time I load a track it spikes.

    Is my solution to boot back to Vista even though it is terrible?

    Any help appreciated.
    Cheers

  2. #2
    Tech Guru BradCee's Avatar
    Join Date
    Sep 2009
    Location
    Amazingstoke, UK
    Posts
    4,464

    Default

    strange, i run a win7 dual boot with a dj io with no problems.

    when you say you optimised the performance of windows, what exactly did you do? there is such a thing as over tweaking, possibly you made the system unstable by accident.
    list everything you did and i'll see if i can spot it

    Win 7 / 2x Reloop Contour / Numark M6 /Traktor Pro 2.5
    SoundCloud

  3. #3

    Default

    hey man,

    Yeh, I optomised it using the performance tools. There was a wizard that did it automatically. I got rid of stuff like the fancy windows and start menu, made it look like win 98. grey windows and menu.
    I cant remeber exactly, but it was in the performance tabs in control panel.

    However traktor was spiking the cpu before I did this.
    I dont think it has anything to do withthe DJ I/O.
    I store my tunes on a portable hard drive though as I have a rather large collection.
    This might possibly be the issue?

  4. #4
    DJTT Infectious Moderator photojojo's Avatar
    Join Date
    Apr 2010
    Location
    Sherman, TX
    Posts
    13,939

    Default

    Quote Originally Posted by ClitEastwood View Post
    I store my tunes on a portable hard drive though as I have a rather large collection.
    This might possibly be the issue?
    Try putting some songs on the hard drive and playing them from there.
    Chris Jennings FHP

    Podcast - Soundcloud - Mixcloud - Beatport Charts - x

  5. #5

    Default

    Hey jo,

    That seemed to kill the cpu spikes. I loaded a folder to the system drive and rattled through loading them and cpu hovered around 25%.
    However with my previous install on vista it never spiked when loading from the hard drive.
    Could the fact that I have reinstalled, and restored by settings by copying the traktor folder in my documents and simply pasting it in after the re install?
    These were the instructions give on the NI website, im going to try using the import function and importing the collection in traktors options to see if this solves it.

  6. #6

    Default

    that failed, epicly.

  7. #7
    Tech Guru BradCee's Avatar
    Join Date
    Sep 2009
    Location
    Amazingstoke, UK
    Posts
    4,464

    Default

    Quote Originally Posted by ClitEastwood View Post
    hey man,

    Yeh, I optomised it using the performance tools.
    that's all you did? - i expected a list of things that would lead to instability

    i went through the services and killed everything that was useless for a traktor boot, have about 19 process including traktor running.
    disabled; wif-fi, lan card, dvd, webcam and a couple of other devices
    also switched out the explorer shell for traktor - literally the only program running.
    plus the wizard

    admittedly i didn't have huge problems running it before i did that (2ghz single core, 2gb ram), but doing all that allowed me to push traktor beyond 2 decks and a few effects to 4 decks and some effects.

    are you running the indexing service? as a thought, if you are turn it off. i know it's designed to improve search times etc... but maybe as your tracks are on an external drive, loading them is getting interference from that? don't have it running on mine and all is well
    Last edited by BradCee; 08-12-2010 at 01:11 PM.

    Win 7 / 2x Reloop Contour / Numark M6 /Traktor Pro 2.5
    SoundCloud

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •