MF Masher and FX not working
Results 1 to 3 of 3
  1. #1
    Tech Student
    Join Date
    Apr 2010

    Question MF Masher and FX not working

    Hi all,

    First of all, thanks to Ean and the whole DJTT team for bringing me into controllerism and Sanwa buttons punching making noise that my neighbours do not necessarily enjoy.
    The community around this blog is impressive and really convinced me to dig in further and try it out. Now because of that I finally decided to jump the gap and to buy a Midi Fighter with the last batch. The beast came in yesterday, and after several hours of testing, I do face some issues I wanted to share.

    My config : TSP 1.24 + OSX 10.6, and a MF with the most recent 1.1 official mapping (not the deckalized one).
    What works well : Cue points, assigning and deleting with Shift, the delay and LoFi FX (the 2 center buttons of the second row), Sync, Pause and Play.
    What works so and so : Certain LEDs sometimes stay on for no particular reason, in the 2 rows of cues for instance.
    What seems completely messed up : the Masher and reslicing of it, the echo function too. When I engage the masher, with FX 3&4 being set to the proper focused deck, it turns it on but since the first knob is set to 0, no sampling happens at all. When I try changing the parameters with the 3 FX buttons on the 2nd row, nothing happens either (makes sense). And the reslicing through Shift+Masher does turn all LEDs on but no effect on sound at all (since the Masher is not working either I guess).

    What I already tried to fix it : I checked that I had the 4 FX banks on. I checked that they were assigned to the right deck. I tried changing the first BeatMasher know with the mouse to give it a value, and then it does effect the sound, then snapshotting in traktor with the camera button for these default masher settings, but as soon as I reengage the masher with the MF, it goes all back to the original settings (which do not work for some reason).

    Anyone facing issues with this too? It looks to me like there is something obvious I have not done since the Mapping works for most of you, I have no idea what at this point.

    Any help is appreciated!

  2. #2
    Tech Guru Gryz's Avatar
    Join Date
    Jan 2010


    Basically the same issue. I would like to know why the FX are not working properly.
    CDJ400s, Ecler Nuo, XD 53
    KRK RP8sFG

  3. #3


    Yeah I'm in the same boat, I'm looking in to re-mapping the effects myself but Im a newb so it may take some time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts