Analyze is screwing up my BPMs
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1

    Default Analyze is screwing up my BPMs

    I got a serious problem on my hands. Ive looked around and seen other posts on this however no one has seemed to answer this issue.

    I use Mixed in Key to analyse the tempo and the key of each song. This info is written to my tracks. I important the tracks into traktor (without analyzing)
    So far so good...
    Problem: When I load a track into a deck, the analysis starts and its at this point that it changes the BPMs ive already calculated. I know analyze is important for peaks and what not but I dont want it tampering with my already calculated BPMs. for Example: I have a 90 BPM track, it analyzes and its either /2 or *2. I know you can change that in grid but I dont want to do that for each song. My entire collection is now being compromised each time I load a track into a deck.

    How can I stop this?!

    Much appreciated.

  2. #2
    Tech Guru
    Join Date
    May 2010
    Location
    Gainesville/Miami Florida
    Posts
    953

    Default

    First off, programs like Mixed in Key has been proven to be very wrong:

    http://www.djtechtools.com/2009/11/0...are-smackdown/

    As far as our issue, I have heard stories of MIK messing with things such as ID3 tags and such, thus messing with Traktor imports and such. I suggest not using MIK. Sorry if that is not the answer you were looking for.
    GPS of Fresh Wet Paint | "Always Fresh n' Sticky"
    DJEditorHugger

    Fresh Wet Paint: Facebook | Twitter | Soundcloud | Site
    GPS: Facebook | Twitter | Soundcloud

  3. #3
    Tech Guru Gryz's Avatar
    Join Date
    Jan 2010
    Location
    Pennsylvania
    Posts
    690

    Default

    Get a keyboard and find the key yourself. Heck, you can even find online keyboards to play. That's what I do on a plane or am somewhere where I don't have my synth.
    CDJ400s, Ecler Nuo, XD 53
    KRK RP8sFG


  4. #4
    Tech Guru lethal_pizzle's Avatar
    Join Date
    Feb 2009
    Location
    Maida Vegas, London
    Posts
    2,816

    Default

    If we're talking Traktor then untick analyse on deck load in the preferences
    DJTT Nu Disco Mix Train Vol 1
    beats and balearic bobs in north-west london
    iTunes podcast
    soundcloud

  5. #5
    Tech Guru Garygary1's Avatar
    Join Date
    Nov 2010
    Location
    Philadelphia, PA, USA
    Posts
    975

    Default

    mess around with BPM detection range in the file management section of your preferences. I normally set the parameters so that the analyse function can't detect the bpm as x2 or 1/2. then just reanalyse the tracks that were wrong.

  6. #6

    Default

    Hey guys,
    thanks for the replies.

    I read that article and even though it claims that mixed in key didnt work as well im still up for testing it myself and seeing how it works out. I was BPMing my tracks 1 by 1 for over the last year and I decided to use MiK because I need to save time and be able to DJ or ill just turn into a librarian. As for getting the key myself. I don't have any classical music training so for now I am unable to calculate it myself. I do have a good ear for music though so im willing to test out MiK and see what happens.

    Quote Originally Posted by lethal_pizzle View Post
    If we're talking Traktor then untick analyse on deck load in the preferences
    I did remove analyze on deck load except now I have a track that isnt analyzed for peaks in the mini browser below. Having the Striped waveform is essential.


    Quote Originally Posted by Garygary1 View Post
    mess around with BPM detection range in the file management section of your preferences. I normally set the parameters so that the analyse function can't detect the bpm as x2 or 1/2. then just reanalyse the tracks that were wrong.
    Where do you set it so that it can't detect and x2 or 1/2?? My BPM detections in both traktor and MiK are set from 60 - 190 because my music varies from Hiphop/R&B to soul, funk, drum-n-bass/jungle, acid jazz, so my numbers have been from mid 50's all the way to 170s. I dont mind correcting a few tracks but this analyze problem is literally messing with ALL tracks.

    I'm wondering, can this have anything to do with Id3 Tag versions?? because right now itunes it making all my tags at v 2.4 . When I was manually BPMing and writing my tracks one by one I was doing them in ver 2.3 and they didnt seem to get messed with.

  7. #7
    Tech Guru Garygary1's Avatar
    Join Date
    Nov 2010
    Location
    Philadelphia, PA, USA
    Posts
    975

    Default

    just make that 60-190 ratio narrower to around the ball park for most of your songs. for me, I have it set to 115-138 because the majority of my tracks are tech-house and minimal. I also have a drum and bass folder, so when i'm loading that, I set it to 155-185.

    Being a dj, odds are you know the approximate BPM of most of your tracks. if you have to do lots of music, separate your tracks into "fast", "Medium" and "Slow" playlists and set the BPM detection parameters to a general ball park range, maybe 30 BPM in between the top and bottom of that range.

    When your done, just go thru the track collection and fix any of the tracks that are still wrong.

    Btw, I use mixed in key and the id3 tags don't affect the BPM detection by traktor
    Last edited by Garygary1; 01-01-2011 at 09:35 PM.

  8. #8

    Default

    Quote Originally Posted by Garygary1 View Post
    just make that 60-190 ratio narrower to around the ball park for most of your songs. for me, I have it set to 115-138 because the majority of my tracks are tech-house and minimal. I also have a drum and bass folder, so when i'm loading that, I set it to 155-185.

    Being a dj, odds are you know the approximate BPM of most of your tracks. if you have to do lots of music, separate your tracks into "fast", "Medium" and "Slow" playlists and set the BPM detection parameters to a general ball park range, maybe 30 BPM in between the top and bottom of that range.

    When your done, just go thru the track collection and fix any of the tracks that are still wrong.

    Btw, I use mixed in key and the id3 tags don't affect the BPM detection by traktor
    My issue is mainly with Traktor analyzing my BPMs when I just want it to leave my files alone. Is there a way to have it just analyse the waveform and not touch the BPM? With some HipHop and electronic music its tuff because I have several albums which play around 150-170 but have a track or 3 that are just 70-80. I'm alright with the BPMs im getting from MiK, I just want traktors hands off my already BPM'd files.

  9. #9
    Tech Guru Garygary1's Avatar
    Join Date
    Nov 2010
    Location
    Philadelphia, PA, USA
    Posts
    975

    Default

    Personally, when I use the mixed in key, i only use it to determine the key and I don't write new id3 tags. I determine the BPM inside of traktor because that is what enables you to use the sync function, or, in the case of timecoding, lets you use that little bar above the waveform to visually tell if your tracks are in time.

    You can't turn off the the bpm detection in traktor because the beatgridding function ("striped waveform") IS the BPM detection. Also, traktor cannot read MIK's bpm detection.

  10. #10

    Default

    Quote Originally Posted by Garygary1 View Post
    You can't turn off the the bpm detection in traktor because the beatgridding function ("striped waveform") IS the BPM detection. Also, traktor cannot read MIK's bpm detection.
    Ahhh ok then that makes sense.
    Do you know of any reliable BPMing programs besides traktor that will calculate the BPM and that traktor wont touch the BPM.
    I know it won't touch it for some because when I was manually entering them with a seperate ID3 tag editor and it was to 1 decimal place, traktor wasnt changing them when they were analyzed.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •