Problem with two controllers in Traktor Pro
Results 1 to 5 of 5
  1. #1
    Tech Student
    Join Date
    Dec 2010
    Posts
    2

    Default Problem with two controllers in Traktor Pro

    Hi,i have set up to Traktor Pro two 2 midi controllers the Akai Apc 40 with this TSI
    http://www.native-instruments.com/fo...4&d=1280754937
    http://www.native-instruments.com/fo...t=97987&page=2
    and the Reloop digital jokey interface edition 2 with the original tsi file.
    Everything was going well until one day the apc started to confuse for example when i adjust the volume fader it change and the dry wet knob the loop size change and the browser list and other crazy things.
    When i have import only the apc tsi its ok the same with the reloop tsi both tsi make sh...
    I have noticed that the problem faders and knobs have the same name in the mapp ch 1 cc 15,ch 1 cc 22, and if i delete it from the one controller the other play well but this is not a solution.
    My question is how in the beginning everything works fine and then spoiled and how can i fix it.

  2. #2
    Tech Wizard
    Join Date
    Apr 2010
    Location
    San Francisco, CA
    Posts
    92

    Default

    Depending on your OS or if you use a USB hub or something, Traktor can mess up the In-Port and the Out-Port of controllers. Whenever you plug a controller in, and especially if you're going to use another person's tsi, be sure to go in your Controller Manager and select the In-Port and Out-Port for each controller.

    This is usually a problem with the General MIDI, in that the two or more MIDI channels can conflict with each other.
    Macbook, Novation Ultranova, Novation Launchpad x2, Behringer BCD3000, Allen & Heath Xone 1D x2 (I'm trying to sell these right now), Traktor Scratch Pro v1.2.7 (It's Legal)
    http://www.facebook.com/dynamicsmusic
    http://soundcloud.com/dynamicsmusic

  3. #3
    DJTT Administrator del Ritmo padi_04's Avatar
    Join Date
    Nov 2009
    Location
    Argentina
    Posts
    6,523

    Default

    Quote Originally Posted by Dynamics View Post
    Depending on your OS or if you use a USB hub or something, Traktor can mess up the In-Port and the Out-Port of controllers. Whenever you plug a controller in, and especially if you're going to use another person's tsi, be sure to go in your Controller Manager and select the In-Port and Out-Port for each controller.

    This is usually a problem with the General MIDI, in that the two or more MIDI channels can conflict with each other.
    ^
    this

    the apc uses 9 midi channels so it's pretty easy for it to conflict with other controllers

  4. #4
    Tech Student
    Join Date
    Dec 2010
    Posts
    2

    Default

    I use windows 7 and a toshiba laptop, i have try to connect to different USB ports but it's the same,I wander if a software like bome's midi translator can help me with this
    The strange thing in the whole case is that in the first time I have connect the two controller's everything work's fine and about a month,and one nice day....
    Thanks for your response and sorry for my English.

  5. #5
    Tech Guru josh@firestorm's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, Australia
    Posts
    1,652

    Default

    Quote Originally Posted by padi_04 View Post
    ^
    this

    the apc uses 9 midi channels so it's pretty easy for it to conflict with other controllers
    thats madness... but i suppose there are quite a few signals being sent from one of those puppies!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •