Numark Total Control Firmware?
Results 1 to 4 of 4
  1. #1

    Default Numark Total Control Firmware?

    First off I am stupid. I was fucking around with my girlfriends numark and some how I reset the firmware... I guess. So I tried to get a hold of numark about it and they have a really large douche bag problem and I have no clue when they are going to help me. So does anyone have the firmware 1.2 already downloaded so I can fix this horrid thing? Thanks!
    SyblingQ - Electro House for dark alleys.

  2. #2


    Never mind I found it. If anyone else has this problem goto:
    SyblingQ - Electro House for dark alleys.

  3. #3
    Tech Student
    Join Date
    Apr 2010


    cheers man been looking for that!

  4. #4


    sorry to dig up an old thread. but im having problems with this file. i tried to update with 2 different sysex loaders but both have failed terribly. it just gets stuck at the sending of the syx file. the lights flash but nothing happens. it doesn't complete the sending.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts