APC40 + Traktor Scratch Pro 2 LED issues
Results 1 to 4 of 4
  1. #1
    Tech Convert
    Join Date
    Jun 2010
    Posts
    10

    Default APC40 + Traktor Scratch Pro 2 LED issues

    I recently upgraded from Traktor Scratch Pro 1 to Traktor Scratch Pro 2 and when adding input mapping data to my APC40 controller mapping tonight traktor2 decided to stop behaving correctly. It seems what's happening is that traktor only sends output data on startup (it seems to be sending output data to the LED rings around the APC knobs, but not the the LED output data for the 40-pad grid on the APC). After I press any of the pads the LEDs turn off. I have them set to control 4 decks and the light-up pads are where I get my information on what's going on in traktor (i.e. the pads mapped to effects are green and blink when effects are turned on, the sync button blinks when a track is synced, etc). Without the pads lighting up it's very difficult to remember what pad does what on the grid.

    I know it is not a hardware problem because my friend's APC40 has the same problem when we plug his APC40 into my copy of TP2, but when I load up the exact same mapping in my or his old version of traktor 1 we do not have any problems with the LEDs! (Of course not, as we've had this mapped for many months now).

    Why is Traktor 2 breaking my mapping? Any idea on how to fix this so traktor will send output data (if this is indeed the problem)?

    If anyone wants to test the mapping out and see if they have the same problem I'll upload once I get back on my computer. Right now I'm not on my laptop.

    Thank you for any help you can offer me!

    Chris
    Last edited by chrisdavis; 04-14-2011 at 08:47 PM. Reason: additional information

  2. #2
    Tech Mentor Paka Ono's Avatar
    Join Date
    Jan 2011
    Location
    The middle of nowhere
    Posts
    495

    Default

    Assuming this is on a PC. Search is your friend - http://www.djtechtools.com/forum/showthread.php?t=17497

    And yes Drew is the fucking man.

  3. #3
    Tech Convert
    Join Date
    Jun 2010
    Posts
    10

    Default

    I'm on a Mac

  4. #4
    DJTT Administrator del Ritmo padi_04's Avatar
    Join Date
    Nov 2009
    Location
    Argentina
    Posts
    6,523

    Default

    Map a Send Monitor State command on a button and tick "Invert" box (so the update occurs when you release the button). If it fixes it, repeat for every conflicting button.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •