MF and VCI possibly fried?
Results 1 to 7 of 7
  1. #1
    Tech Mentor soerensus's Avatar
    Join Date
    Feb 2009
    Location
    Denmark
    Posts
    153

    Default MF and VCI possibly fried?

    I've had my Midifighter for a good 9 months now and my VCI for over a year. But last week I had a accident with my computer (15" macboook pro) where I plugged the Midifighter and my VCI in a unpowered usb-hub and the usb-ports turned off. The thing was that the usb-ports didn't turn back on when I restarted the computer. I send it to be repaired, they couldn't fix it so I got a new one. Today I got my "Time Machine" backup installed on my mac.

    As i plug in my VCI there is no lights turning on, no power light, no data send, nothing. I found that very weird and I checked my MidiFighter as well.

    The MidiFighter when plugged in makes the flashy light start-up but then just lights the bottom right corner. I can go in to menu mode and boot mode but I can't get it to send any midi to Traktor. The buttons don't either light up when pressed.


    Am I completely F****** or do anyone have any idea how to fix this.

    I've been crying all afternoon.
    HEEEEEELP! (please)
    13"MBP - VCI-100B - M-audio oxygen 8 - Maschine - Midi Fighter[DEAD] - Audio2Dj - KRK RP8

  2. #2
    Tech Mentor dual citizen's Avatar
    Join Date
    Mar 2010
    Location
    Austin, Texas
    Posts
    385

    Default

    I'm assuming that you're plugging your VCI and Midifighter directly into your Macbook and not into that USB hub?

  3. #3
    Tech Mentor soerensus's Avatar
    Join Date
    Feb 2009
    Location
    Denmark
    Posts
    153

    Default

    Yes. Tried both usb-ports.
    13"MBP - VCI-100B - M-audio oxygen 8 - Maschine - Midi Fighter[DEAD] - Audio2Dj - KRK RP8

  4. #4
    Tech Mentor
    Join Date
    Apr 2011
    Location
    Bologna, Italy
    Posts
    116

    Default

    the MF could just need a re-flash.
    fingercross for your VCI.... :|

  5. #5
    Tech Mentor soerensus's Avatar
    Join Date
    Feb 2009
    Location
    Denmark
    Posts
    153

    Default

    re-flash?
    13"MBP - VCI-100B - M-audio oxygen 8 - Maschine - Midi Fighter[DEAD] - Audio2Dj - KRK RP8

  6. #6
    Tech Mentor
    Join Date
    Apr 2011
    Location
    Bologna, Italy
    Posts
    116

    Default

    flash the firmware again

  7. #7
    Tech Mentor soerensus's Avatar
    Join Date
    Feb 2009
    Location
    Denmark
    Posts
    153

    Default

    Ah. Ill try that. Have any experience if its easier to do it on a mac or pc? For my VCI hopefully I can get it repaired, we are running out of black versions here.

    The Midifighter I can't get repaired. Would cost a fortune to ship it from Denmark to San Francisco and back.
    13"MBP - VCI-100B - M-audio oxygen 8 - Maschine - Midi Fighter[DEAD] - Audio2Dj - KRK RP8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •