X1 button issues / Experiences with NI repairs?
Results 1 to 9 of 9
  1. #1
    Tech Guru Alex Wild's Avatar
    Join Date
    Sep 2010
    Location
    London, UK
    Posts
    565

    Default X1 button issues / Experiences with NI repairs?

    My X1 has started getting a bit unresponsive on certain buttons, mainly the play buttons as I probably use those most!
    They still work, but need a very firm press instead of the usual tap that normally works.

    Is this a common problem?

    Has anyone got experience with sending stuff back to NI for repair? How long does it usually take, are they reliable?
    Mixes: www.mixcloud.com/djalexwild/
    Production: www.soundcloud.com/alexwild
    DJM500 : X1 : MBP 15" 2.53 GHz 4 GB RAM : HD25SP : MASCHINE

  2. #2
    Tech Guru djproben's Avatar
    Join Date
    Aug 2009
    Location
    Hollywood, CA
    Posts
    2,705

    Default

    I had to get an X1 replaced. Once I got through to them and got it set up (which took months; even to get a response at all I had to make noise on the NI web forum and get Karlos to look into it) the rest went smoothly. For me the annoying part was having to pack up the X1 and mail it ... I literally live down the street from NI and asked if I could walk it over rather than packing it up and taking it a mile away to the post office and paying postage to send it, and they said no. Strange but oh well. Anyway once I sent it I received the replacement within about a week.
    "Art is what you can get away with." - Marshall McLuhan

  3. #3
    Tech Mentor jezalenko's Avatar
    Join Date
    May 2011
    Location
    Perth, Australia
    Posts
    260

    Default

    Great. My S4 is having problems with one of the loop encoders, and NI have been very quiet since I filed a ticket with them, and no a single reply on the NI forums....

    A PM to Karlos might be in order....
    Dell Studio XPS 1645 | TSP 2.6 | Kontrol S4 | Audio 6 | HDJ-1000 | Alto PAM5A

  4. #4
    Tech Guru Alex Wild's Avatar
    Join Date
    Sep 2010
    Location
    London, UK
    Posts
    565

    Default

    Djproben, what was the problem with your X1? I'm wondering if anyone else has had the same issue with the buttons. It seems that its worse on the left play button. Ive just had another play with it and it needs a real firm press to respond.
    Has anyone taken an X1 apart? I want to see if something is stuck under the button or if its dirty. I took all the screw out the back but the two halves still dont come apart. There's a bit of movement around the edges, but it seems like something is holding it at the top and bottom of the unit. Any ideas?
    Mixes: www.mixcloud.com/djalexwild/
    Production: www.soundcloud.com/alexwild
    DJM500 : X1 : MBP 15" 2.53 GHz 4 GB RAM : HD25SP : MASCHINE

  5. #5
    DJTT Infectious Moderator photojojo's Avatar
    Join Date
    Apr 2010
    Location
    Sherman, TX
    Posts
    13,939

    Default

    Quote Originally Posted by Alex Wild View Post
    Has anyone taken an X1 apart? I want to see if something is stuck under the button or if its dirty. I took all the screw out the back but the two halves still dont come apart. There's a bit of movement around the edges, but it seems like something is holding it at the top and bottom of the unit. Any ideas?
    [ame="http://s104.photobucket.com/albums/m179/alientek/NI%20X1%20TEARDOWN%20AND%20MOD/"]NI X1 TEARDOWN AND MOD pictures by alientek - Photobucket[/ame]
    Chris Jennings FHP

    Podcast - Soundcloud - Mixcloud - Beatport Charts - x

  6. #6
    Tech Guru Alex Wild's Avatar
    Join Date
    Sep 2010
    Location
    London, UK
    Posts
    565

    Default

    Cheers photojojo. So it'll void warranty by trying to fix it myself... Now, do I try it anyway or just send it to NI? Dont know if i'll manage without it for very long...
    Mixes: www.mixcloud.com/djalexwild/
    Production: www.soundcloud.com/alexwild
    DJM500 : X1 : MBP 15" 2.53 GHz 4 GB RAM : HD25SP : MASCHINE

  7. #7
    DJTT Infectious Moderator photojojo's Avatar
    Join Date
    Apr 2010
    Location
    Sherman, TX
    Posts
    13,939

    Default

    If you have electronics experience and think you can do some soldering then you might be able to fix it. I think I could probably do it, but I would still send it on and have them do it. I have more than one thing I can use in its place though.
    Chris Jennings FHP

    Podcast - Soundcloud - Mixcloud - Beatport Charts - x

  8. #8
    Tech Guru Alex Wild's Avatar
    Join Date
    Sep 2010
    Location
    London, UK
    Posts
    565

    Default

    I was thinking that it might just be some dust or dirt getting between the pad and the button, but even having a look in there is going to screw my warranty, so I guess i'll just send it in. Do you know if you have to take it to the shop to send it back or can you send it direct to NI yourself?
    Mixes: www.mixcloud.com/djalexwild/
    Production: www.soundcloud.com/alexwild
    DJM500 : X1 : MBP 15" 2.53 GHz 4 GB RAM : HD25SP : MASCHINE

  9. #9
    Tech Guru djproben's Avatar
    Join Date
    Aug 2009
    Location
    Hollywood, CA
    Posts
    2,705

    Default

    It wasn't sending midi, or it was sending it erratically as I recall. Really frustrating; it worked fine in HID mode but in MIDI mode it was useless.

    Quote Originally Posted by Alex Wild View Post
    Djproben, what was the problem with your X1? I'm wondering if anyone else has had the same issue with the buttons. It seems that its worse on the left play button. Ive just had another play with it and it needs a real firm press to respond.
    Has anyone taken an X1 apart? I want to see if something is stuck under the button or if its dirty. I took all the screw out the back but the two halves still dont come apart. There's a bit of movement around the edges, but it seems like something is holding it at the top and bottom of the unit. Any ideas?
    "Art is what you can get away with." - Marshall McLuhan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •