Using two audio devices w/ ASIO4all in traktor de-syncing issue
Results 1 to 8 of 8
  1. #1

    Default Using two audio devices w/ ASIO4all in traktor de-syncing issue

    Whatsup DJTT!

    So right now, I am using two audio devices for djing in traktor using the asio4all drivers to use the usb soundcard's output as master and the laptop's soundcard as monitor. What happens after 20-30 min. or so is that the two audio streams become de-synced and the only real solution is to open up the ASIO4all control panel and then close it, but then that puts like a .2 sec stop in the stream and its a REALLY bad thing to happen when playing out live. (even for bedroom mixing, still...)

    I've tried making the two devices have the same amount of samples, and both are resampling to 44.1 khz, etc etc but they still de-sync after so long.

    Is there any other software that forces the two audio devices to have the same sync? Or is there anything else i can do to keep the two devices synced? Im clueless at the moment - the only thing i can think of would be to just listen to which device desyncs and how to compensate by raising or lowering latency but that seems too time-consuming...

    In the long-run i will be upgrading to a legit dj audio interface such as ni audio 2 or numark dj io but for now i must put up with this horrific issue... (which btw, what would you guys recommend for a <100-120 audio card? Ive been reading that audio 2 is the best in that price range, i have no need for extra inputs or outputs atm)

  2. #2
    Tech Guru Sherlock Ohms's Avatar
    Join Date
    Jun 2009
    Location
    Bristol, UK
    Posts
    1,601

    Default

    Seriously, I'd just buy an Audio 2 or equivalent - they're pretty cheap and will remove this issue.

    (fair play to your inventiveness for getting this working mind you ...)
    Traktor Scratch Pro 2/Serato SL1/Ecler NUO 3.0/VCI 100 SE/2 x Technics 1210 Mk2/Sennheiser HD25 II/Novation Dicers

  3. #3
    DJTT Moderator Dude Jester's Avatar
    Join Date
    Feb 2009
    Location
    New Zealand
    Posts
    12,370

    Default

    get an audio 2 mate
    Acer E5 i7 2TB 16GB ~ 512GB SSD ~ WIN 10 ~ TSP 2.11 ~ AUDIO 6 ~ X1 ~ DN-X1600 ~ X1 ~ SPECTRA ~ TWISTER ~ ATH-PRO500 MK2 ~ AT2020 MIC

    "This aggression will not stand, man."

  4. #4
    Tech Guru lethal_pizzle's Avatar
    Join Date
    Feb 2009
    Location
    Maida Vegas, London
    Posts
    2,816

    Default

    +1 to getting a proper soundcard
    DJTT Nu Disco Mix Train Vol 1
    beats and balearic bobs in north-west london
    iTunes podcast
    soundcloud

  5. #5

    Default

    okay yeah ill just bone up for the soundcard..any thoughts on numark dj io or audio 2? (and please explain why)

  6. #6

    Default

    woot woot! I just did a goog search and found that guitar center has audio 2's for pretty cheap. got one for 59.99 + tax and sh came out to around 71 bux. Hoooray deals!

  7. #7
    Tech Guru Sherlock Ohms's Avatar
    Join Date
    Jun 2009
    Location
    Bristol, UK
    Posts
    1,601

    Default

    And your woes are over (or at least these ones are ...)
    Traktor Scratch Pro 2/Serato SL1/Ecler NUO 3.0/VCI 100 SE/2 x Technics 1210 Mk2/Sennheiser HD25 II/Novation Dicers

  8. #8

    Default

    Maybe you already went and bought a sound card, but for anyone else reading this and having the same problem: Try changing the Sample Rate to 48 kHz, since 44.1 kHz is known to cause some problems with de-synching. Worked for me!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •