iMix MIDI trouble
Results 1 to 5 of 5
  1. #1
    Tech Student
    Join Date
    Nov 2011
    Posts
    3

    Default iMix MIDI trouble

    Hey there, my name is Aaron and I'm a noobie in the mixing game. I just bought my first mixer, a DJ-Tech i-Mix, to use with my MacBook Pro 13" (10.6.8), and when I plug it in, the POWER light turns on, but none of the buttons register. The computer seems to recognize that it is connected (using various dj programs to see if it was a software issue), but even running an automatic mapping doesn't get anything.

    I've tried a few restarts, but nothing yet. I use VirtualDJ 7.

    I also may hang around this forum more in the future as well, I want to get better at mixing and I have a lot of forum experience

    Thanks guys!

  2. #2
    Über Tech Guru Ed Paris's Avatar
    Join Date
    Jun 2008
    Location
    l.e. city / germany
    Posts
    4,011

    Default

    do you plug in both usb as well as the power supply?
    I'm just a girl, standing in front of a boy, asking him to love her.
    FB/Ed Paris
    MC/Ed Paris
    FB/Wallach
    SC/Wallach

  3. #3
    Tech Student
    Join Date
    Nov 2011
    Posts
    3

    Default

    Quote Originally Posted by earl panda View Post
    do you plug in both usb as well as the power supply?
    Just USB. I dont have a power supply!

  4. #4
    Über Tech Guru Ed Paris's Avatar
    Join Date
    Jun 2008
    Location
    l.e. city / germany
    Posts
    4,011

    Default

    Quote Originally Posted by Insane54 View Post
    Just USB. I dont have a power supply!
    maybe this could be the reason but i don´t know. i don´t have an imix but maybe someone else on here.
    I'm just a girl, standing in front of a boy, asking him to love her.
    FB/Ed Paris
    MC/Ed Paris
    FB/Wallach
    SC/Wallach

  5. #5
    Tech Student
    Join Date
    Nov 2011
    Posts
    3

    Default

    I talked to the people at DJ Tech and they recommended buying a USB hub, which did the trick!

    Unfortunately though, VirtualDJ doesn't seem to have a mapper that actually works so I had to do it manually. Does anyone know what the values would be to get the LEDs to work?

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <mapper device="SIMPLE_MIDI" author="Atomix Productions" description="Simple MIDI wrapper" version="703" date="03/11/2011" priority="-10">
      <map value="0-20" action="deck 1 play_pause" />
      <map value="0-CC65" action="crossfader" />
      <map value="0-18" action="deck 1 seek -4" />
      <map value="0-25" action="deck 1 seek +4" />
      <map value="0-2" action="toggle &quot;shift&quot; while_pressed" />
      <map value="0-9" action="deck 1 var &quot;shift&quot; ? delete_cue 1 : hot_cue 1" />
      <map value="0-16" action="deck 1 var &quot;shift&quot; ? delete_cue 2 : hot_cue 2" />
      <map value="0-23" action="deck 1 var &quot;shift&quot; ? delete_cue 3 : hot_cue 3" />
      <map value="0-17" action="deck 1 select" />
      <map value="0-7" action="deck 1 automix" />
      <map value="0-5" action="deck 1 sync" />
      <map value="0-6" action="deck 1 vinyl_mode" />
      <map value="0-13" action="deck 1 cue" />
      <map value="0-1" action="deck 1 loop_in" />
      <map value="0-8" action="deck 1 loop_out" />
      <map value="0-15" action="deck 1 reloop" />
      <map value="0-14" action="deck 1 pitch_bend -1% 500ms" />
      <map value="0-22" action="deck 1 pitch_bend +1% 500ms" />
      <map value="PITCH_RANGE" action="var &quot;shift&quot; ? key_lock : pitch_range +1" />
      <map value="0-3" action="deck 1 reverse" />
      <map value="0-10" action="var &quot;shift&quot; ? browser_folder : browser_enter" />
      <map value="0-32" action="deck 1 eq_kill_high" />
      <map value="0-28" action="deck 1 eq_kill_mid" />
      <map value="0-21" action="deck 1 eq_kill_low" />
      <map value="0-82" action="browser_scroll +1" />
      <map value="0-83" action="browser_scroll -1" />
      <map value="0-CC68" action="deck 1 pitch" />
      <map value="0-CC67" action="deck 1 volume" />
      <map value="0-CC72" action="deck 1 gain" />
      <map value="0-CC69" action="deck 1 eq_high" />
      <map value="0-CC70" action="deck 1 eq_mid" />
      <map value="0-CC71" action="deck 1 eq_low" />
      <map value="LED_PLAY_PAUSE" action="play ? on : pause ? blink : off" />
      <map value="0-84" action="deck 1 jogwheel +0.01" />
      <map value="0-85" action="deck 1 jogwheel -0.01" />
      <map value="0-55" action="deck 2 play_pause" />
      <map value="0-31" action="deck 2 seek -4" />
      <map value="0-38" action="deck 2 seek +4" />
      <map value="0-86" action="deck 2 jogwheel +0.01" />
      <map value="0-87" action="deck 2 jogwheel -0.01" />
      <map value="0-CC73" action="deck 2 eq_low" />
      <map value="0-CC74" action="deck 2 eq_mid" />
      <map value="0-CC76" action="deck 2 eq_high" />
      <map value="0-CC75" action="deck 2 gain" />
      <map value="0-CC66" action="deck 2 volume" />
      <map value="0-90" action="deck 2 pitch" />
      <map value="0-80" action="browser_scroll +1" />
      <map value="0-81" action="browser_scroll -1" />
      <map value="0-52" action="deck 2 reverse" />
      <map value="0-45" action="var &quot;shift&quot; ? browser_folder : browser_enter" />
      <map value="0-36" action="deck 2 loop_in" />
      <map value="0-43" action="deck 2 loop_out" />
      <map value="0-50" action="deck 2 reloop" />
      <map value="0-48" action="deck 2 cue" />
      <map value="0-41" action="deck 2 vinyl_mode" />
      <map value="0-49" action="deck 2 pitch_bend -1% 500ms" />
      <map value="0-29" action="deck 2 pitch_bend +1% 500ms" />
      <map value="0-39" action="deck 2 eq_kill_high" />
      <map value="0-35" action="deck 2 eq_kill_mid" />
      <map value="0-42" action="deck 2 eq_kill_low" />
      <map value="0-12" action="deck 2 sync" />
      <map value="0-56" action="deck 2 play_sync" />
      <map value="0-24" action="deck 2 select" />
    </mapper>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •