Big problem for a beginner
Results 1 to 5 of 5
  1. #1

    Default Big problem for a beginner

    Ok, so I joined a uni dj society a couple of months ago and got vestax typhoon for christmas. I was really enjoying them, but they would randomly stop working throughout the day and then restart working again anything from 10 minutes to an hour later. I don't know what was causing it. But then when I tried using them today they just won't work all together. I'm using them with virtual dj LE 7. When I link them with the usb the lights all come on on the typhoon and the touch sensitive decks still go red when you touch the silver bit. Also, i can still scroll through the song list and load songs. When I press play or sync, it acknowledges that i've pressed it on the screen, but the music just won't play. It's not loading, it just won't start. I've uninstalled and reinstalled the ASIO4TYPHOON and virtual dj but it makes no difference now. I'm using it with Vista if that makes any difference. I hope someone can help me because I know nothing about trying to fix this kind of thing. I've read around a lot today but people start talking about mapping and different asios and midis and I have no clue what any of those things are. I feel really bad because it was a gift given from my parents who must have saved to get it and now after one day I don't know what's wrong with it :/

  2. #2


    Im not an expert not even near but sometimes that happen to me in my s4
    I just turn off the pc and turn it on when it happens alot i reinstall the drivers and the software
    You need to close all the programs too and the wifi and bluetooth everything off

    The problem i think its not in the hardware its in the software thats all i can help you sorry

  3. #3
    Tech Guru Steve Zorilow's Avatar
    Join Date
    Apr 2010
    Montréal, Québec, Canada


    Audio Driver issue seems plausible. try something, change the audio card for the laptop one instead and see if it does anything better.

    Not better? Get rid of ASIO4ALL and try again.
    Steve Zorilow: Facebook - Soundcloud - Mixcloud - Twitter

  4. #4
    Tech Mentor Lew's Avatar
    Join Date
    May 2011
    Hampshire, UK


    Try running Serato Intro and see if that works. That'll help to diagnose whether the problem is software or hardware.

  5. #5

    Default One problem fixed, another begins

    Ok so i've worked out that all i normally need to do is load the songs to the jogs and start playing them THEN turn the typhoon on and all works. But now i've realised that when i have my head phones plugged in and select which jog I want to hear through headphones and which through speaker, regardless of which I choose I always hear both through the speaker, so I can't hear anything through the headphones. Not sure if anyone has this problem or what i should do again. Thanks for your help though guys

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts