MixTrack URGENT HELP NEEDED!
Results 1 to 9 of 9
  1. #1

    Default MixTrack URGENT HELP NEEDED!

    hello there,

    has anyone ever had problems with their mixtrack hooking up to traktor 2? it works fine on my PC but not my macbook Pro, i've installed the program and that works fine but when i import the mixtrack.tsi file the right deck is constantly playing and the play button wont turn off

    i've had a look for drivers the mixtrack page on the numark site says that it is 'class-compliant USB device' and doesn't need a driver.

    im running OSX 10.7.3, quad-core i7, 4GB RAM, Edirol FA66 sound card.

    i am playing a gig a week on tuesday so any help is desperately needed and would be greatly appreciated!

    thanks in advance, Lucas


  2. #2
    Tech Guru deevey's Avatar
    Join Date
    Oct 2010
    Location
    From Ireland Living in Manila: Philippines :D
    Posts
    3,675

    Default

    If its working at all - then theres an issue with the mapping.

    Have you tried editing the play button or checked anyone else's TSI in the mapping forum or traktor bible ?

    Does everything else apart from the play button work ?

    You might want to list the version of Traktor 2 (e.g. 2.0.1, 2.0.3)

    Also is it the full version of Traktor 2 or Traktor 2 LE ?

  3. #3

    Default

    i'm running a full version of Traktor 2.0.3, i've tried changing the mapping on the standard .tsi that comes with the software, i've also tried getting another .tsi file (from traktorbible.com) and tried fiddling with that.

    the same thing seems to happen, the faders and rotaries work with no problems, but ALL of the buttons are sketchy: most of them don't work at all, the ones that actually light up stay lit even after un-toggling them rendering them useless... this happens even after i've redone the mapping so that it is absolutely correct in corresponding with the mixtrack's buttons.

    the thing that is confusing me the most is the fact that it works absolutely fine on my PC with no hassle...

    the only thing i can think of (it might be because in vaguely noobish) is to back track from lion to snow leopard, because a mate of mine has traktor 2.0.3 with a mixtrack (a slightly newer mixtrack i think) with no problems on snow leopard... but this seems like a bit of an effort, so i'm hoping theres a solution, because i dont even know if that will work lol

    what do you think?

    Lucas
    Last edited by steppinrazor89; 04-06-2012 at 05:41 PM.

  4. #4
    Tech Guru deevey's Avatar
    Join Date
    Oct 2010
    Location
    From Ireland Living in Manila: Philippines :D
    Posts
    3,675

    Default

    Quote Originally Posted by steppinrazor89 View Post
    i'm running a full version of Traktor 2.0.3, i've tried changing the mapping on the standard .tsi that comes with the software, i've also tried getting another .tsi file (from traktorbible.com) and tried fiddling with that.
    Have you tried to use midi learn within Traktor on the buttons/led's rather than relying on the downloaded TSI's? have you checked the modes on the mapped buttons e.g. Toggle/direct etc .. ?

    Back tracking to snow leopard is a lil drastic when its probably just a mapping issue.

    If I were you I would start with a blank TSI to begin with and work backwards - can you get the buttons/led's working that way? ... if yes then its an issue with the TSI and you'll need to edit it or create one.

    Start with mapping the buttons ... once they are working, try for the led's
    Last edited by deevey; 04-06-2012 at 05:43 PM.

  5. #5

    Default

    yeah that would have been my last ditch attempt lol i've redone all of the mapping however i didn't check the modes, i'll redo it again with that in mind and get back to you!

    cheers for the help

  6. #6

    Default



    i'm an absolute noob with trying to map the mixtrack... (this might be because i've been getting pissed off with it for hours) what i am getting confused with is the use of modifiers to select different modes, could you point me in the direction of any decent mapping tutorials?

  7. #7
    Tech Guru deevey's Avatar
    Join Date
    Oct 2010
    Location
    From Ireland Living in Manila: Philippines :D
    Posts
    3,675

    Default

    Quote Originally Posted by steppinrazor89 View Post

    i'm an absolute noob with trying to map the mixtrack... (this might be because i've been getting pissed off with it for hours) what i am getting confused with is the use of modifiers to select different modes, could you point me in the direction of any decent mapping tutorials?
    First thing I'd do is remove literally ALL mappings, start from nothing at all, in your video you didn't delete the old one or the keyboard mapping.

    Like I said, I'd first try to backup and delete all mappings keyboard and all (in case a key is acting intermittent or somethings stuck).

    Map the buttons on both decks only with play/cue/pause etc ... see if that works without anything else loaded.

    IF that works, take note of the Note/CC's you set up and reload the "broken" tsi, search for the Note/cc and make your changes to the stock one - if thats still not working.

    The deck jumping in your vid looks like a jog setting is botched or sending some kind of midi data to Traktor continually (dirty sensor ?)...and maybe thats interfering when you are midi learning as well.

    Good luck

  8. #8

    Default

    Thanks a lot for the help im almost there, i've just got one more hurdle to cross, if you can help? sorry i am a bit nooby with mapping since this is the first mapping that i have tried...


  9. #9
    Tech Guru deevey's Avatar
    Join Date
    Oct 2010
    Location
    From Ireland Living in Manila: Philippines :D
    Posts
    3,675

    Default

    Quote Originally Posted by steppinrazor89 View Post
    Thanks a lot for the help im almost there, i've just got one more hurdle to cross, if you can help? sorry i am a bit nooby with mapping since this is the first mapping that i have tried...
    Sorry I can't help you out any more on this, guessing theirs a toggle or hold set up on possibly the scratch button :-S... I though the top of the jogs on the Numark are touch sensitive though that you can send a modifier from them ?.

    Looks like you are almost there though, I know even on my old hercules getting the jogs sorted out was a combination of weird modifiers like if playing - stop play, if not playing start playing which were duplicated to get the function right. That might be whats missing when you finish a scratch ... e.g. A "play if not playing" if that makes any sense.

    You might be able to extract some of the stuff from the old mapping e.g. delete all the button mapping from the official one (that the play button was screwy on).

    Delete the jog functions from your map

    Load both... x fingers.

    Needless to say back them all up first

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •