SC2000 problems
Results 1 to 5 of 5

Thread: SC2000 problems

  1. #1

    Default SC2000 problems

    Hey all,
    I have this weird issue with my sc2000 in traktor, if I adjust the tempo with the B pitch control, the back nudge (pitch down) button lights up and the track slows down. The only way to get it to work is to unclick the back nudge (pitch down) button.

    The A deck is fine.

  2. #2
    Tech Guru SirReal's Avatar
    Join Date
    May 2010
    Location
    San Fran Bay Area
    Posts
    2,204

    Default

    Do you have the "fader lock" function enabled or disabled on the controller?
    "Walking the fine line between Stupidity and Genious" My Soundcloud ---- My Mixcloud
    MBP Retina 2015--TSP 2.10--2xDNSC5000--2xDNSC2900--2xDNSC2000--NI F1--Denon DN-X1700--HDJ2000--Stanton STR8-80--QSC K12's--Crown Amplifier--Urei Monitors

  3. #3
    Tech Guru SirReal's Avatar
    Join Date
    May 2010
    Location
    San Fran Bay Area
    Posts
    2,204

    Default

    If the fader lock function is set to ON and the pitch slider position
    after a DECK change operation is different from the value registered
    in the unit’s memory, the MIDI command is not sent. The KEYLOCK
    LED fl ashes.
    Once the pitch fader position coincides with the value registered in
    the unit’s memory, MIDI command transmission starts again, and
    the KEYLOCK LED retrieves the status before fl ashing.
    • The default setting is ON.
    To set the fader lock function ON.
    Press the PITCHBEND+ button while holding the SHIFT button
    pressed.
    To set the fader lock function OFF.
    Press the PITCHBEND– button while holding the SHIFT button
    "Walking the fine line between Stupidity and Genious" My Soundcloud ---- My Mixcloud
    MBP Retina 2015--TSP 2.10--2xDNSC5000--2xDNSC2900--2xDNSC2000--NI F1--Denon DN-X1700--HDJ2000--Stanton STR8-80--QSC K12's--Crown Amplifier--Urei Monitors

  4. #4

    Default

    I just tried turning the fader lock off and nothing changed. I'm not even sure it's a setting, I'm be surprised if you could set it so moving the fader in and direction only allows you to play the B deck slower than real time.

  5. #5

    Default

    Ok fixed this, I just removed the multiple tsi files I had installed and added the latest mapping. I guess i must have been using an edit tsi.

    :facepalm:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •