Xone K2 - changing latency ASIO latency settings destroys the universe
Results 1 to 4 of 4
  1. #1
    DJTT Scribe Mod smiTTTen's Avatar
    Join Date
    Jan 2011
    Location
    Then: UK. Now: US.
    Posts
    1,940

    Default Xone K2 - changing latency ASIO latency settings destroys the universe

    Morning Midi Mothers and Audio Uncles,

    Looking for some help on the Xone K2 on Windows 7 (well Windows 8 but both versions exhibit the same symptoms). I am unable to adjust the ASIO latency settings without freezing Traktor. While I would love to spend my life running at 28ms latency, even my fat little fingers need more nimbility* than is currently on offer by the unit.
    I check the A+H forum and A+H themselves recognized the issues back in bloody August!

    http://xoneforum.allen-heath.com/for...-asio-settings

    A+H were good enough to state ďFrom our findings it seems to only affect Windows 7 not XPĒ - I am so pleased that it doesnít affect an operating system thatís almost old enough to have kids

    Anyway, if anyone has a hack/workaround/fix for this itís this global collection of reprobates. There may be a small prize for the person that helps me sort this.

    *yes, this is a word.
    Beats By Dre is like audio flu for your balls.

  2. #2
    Tech Guru
    Join Date
    Mar 2008
    Location
    Seattle, WA
    Posts
    1,464

    Default

    I would try adjusting the latency settings via the original driver applet instead of through the Traktor audio setup. If you're trying to dial in a setting, you'll probably need to select the K2 ASIO driver to test, then de-select it (choose another audio interface), make your changes in the driver applet, then re-select the K2 driver in Traktor, test, rinse and repeat.

  3. #3
    Tech Wizard
    Join Date
    Jun 2009
    Posts
    20

    Default

    I just bought my K2 one month ago. Same deal. I'm really disappointed when things happen like this out the box.

  4. #4
    DJTT Scribe Mod smiTTTen's Avatar
    Join Date
    Jan 2011
    Location
    Then: UK. Now: US.
    Posts
    1,940

    Default

    Quote Originally Posted by nem0nic View Post
    I would try adjusting the latency settings via the original driver applet instead of through the Traktor audio setup. If you're trying to dial in a setting, you'll probably need to select the K2 ASIO driver to test, then de-select it (choose another audio interface), make your changes in the driver applet, then re-select the K2 driver in Traktor, test, rinse and repeat.
    I am going to give this a go a bit later. The next step will be to see if there is a config file I can just edit directly... nah - that would be too easy.....
    Beats By Dre is like audio flu for your balls.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •