Need help! RE: DJM mixer MIDI control
Results 1 to 5 of 5
  1. #1
    Tech Mentor
    Join Date
    Nov 2011
    Location
    Baltimore MD
    Posts
    228

    Default Need help! RE: DJM mixer MIDI control

    Hi y'all,

    I have a DJM 850 and am trying to midi-map some of the controls. Specifically, I want to map the "Fader Start" buttons (that I never use) and map them to toggle on and off Traktor's Slip Mode. This would be pretty cool if I could get it to work! However, I don't know how to have my computer receive midi from the mixer! I have the usb cable connected into the top of the mixer, as I use the DJM's internal sound card. Do I need to connect another usb port to the 5-pin MIDI port at the back of the mixer?

    Cheers

  2. #2
    Tech Guru SlayForMoney's Avatar
    Join Date
    Mar 2012
    Location
    EU
    Posts
    1,703

    Default

    first, check in DJM manual that the "fader start" buttons are MIDI mappable (sometimes, not all buttons and knobs are) and enable midi on the mixer (it has a midi on/off button, right?).
    you do not need another another cable. the rest should be be something as this (anybody, feel free to correct me): go to traktor controller manager, add generic midi controller under "device", select action you want to use with the "add in" button (slip mode), then click "learn" and press the button on the djm. traktor should receive midi from mixer then you click again on "learn" to deactivate it.
    Denon X600 - 2x Denon SC-2000 - AKG K181DJ - NI Audio 2

  3. #3
    Tech Guru
    Join Date
    Mar 2012
    Location
    York, UK
    Posts
    3,428

    Default

    Almost everything on the DJM is mappable; the Fader Starts were mappable on the 800 so they should still be on the 850. And MIDI should work fine going through the USB port on the mixer.
    VCM100 / X1 / DJM250 / DJM900 / CDJ2000s / Maschine / Audio2+4 / 2i4 / HS8s / TSP 2.6.8
    Macbook Air i7-3667U+8GB 10.9 / Win7x64 i5-3570k+24GB


  4. #4
    Tech Guru
    Join Date
    Sep 2010
    Location
    Boston/Worcester
    Posts
    1,067

    Default

    Quote Originally Posted by SlayForMoney View Post
    first, check in DJM manual that the "fader start" buttons are MIDI mappable (sometimes, not all buttons and knobs are) and enable midi on the mixer (it has a midi on/off button, right?).
    you do not need another another cable. the rest should be be something as this (anybody, feel free to correct me): go to traktor controller manager, add generic midi controller under "device", select action you want to use with the "add in" button (slip mode), then click "learn" and press the button on the djm. traktor should receive midi from mixer then you click again on "learn" to deactivate it.
    Yea that's basically it. There is a MIDI On/Off button on the upper right hand of the mixer, so yes that needs to be on. One thing that was missed, is when you make your generic MIDI mapping, you should select the DJM850 as your In-Port in the mapping

  5. #5
    Tech Mentor
    Join Date
    Nov 2011
    Location
    Baltimore MD
    Posts
    228

    Default

    Thanks guys! It turns out that I had the keyboard selected as my midi input (durrdurrdurr), not the DJM-850. That's what I get for mapping at 4am, I guess.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •