Usb 3.0 express card not working with Audio 2
Results 1 to 5 of 5
  1. #1
    Tech Convert
    Join Date
    Apr 2011
    Posts
    15

    Default Usb 3.0 express card not working with Audio 2

    Hey guys, wondering if you can help me out. I have a Lenovo G450 laptop, and my usb ports are all screwed up. So I just bought a SIIG Usb 3.0 express card, thinking this would solve my problem. But When I plug my Audio 2 into it, it recognizes it, but it doesn't actually work. For instance, when I press play in Traktor, the button lights up, but the audio doesn't actually play. The soundwave doesn't even move... Any ideas on why? Did I just throw away $35?

  2. #2
    Tech Mentor
    Join Date
    Dec 2012
    Posts
    402

    Default

    Quote Originally Posted by RianJ View Post
    Hey guys, wondering if you can help me out. I have a Lenovo G450 laptop, and my usb ports are all screwed up. So I just bought a SIIG Usb 3.0 express card, thinking this would solve my problem. But When I plug my Audio 2 into it, it recognizes it, but it doesn't actually work. For instance, when I press play in Traktor, the button lights up, but the audio doesn't actually play. The soundwave doesn't even move... Any ideas on why? Did I just throw away $35?

    There are still continuing issues with native instrument Windows 7 Traktor Audio drivers and USB 3. I had to disable USB 3, run USB in Legacy Mode, and Disable the Intel 3.0 Host Controller in order for me to properly use my Traktor Audio device.

    Your issue may differ and related to something else, but thats just a heads up.

  3. #3
    Tech Guru SirReal's Avatar
    Join Date
    May 2010
    Location
    San Fran Bay Area
    Posts
    2,204

    Default

    Works great with USB2 though.
    "Walking the fine line between Stupidity and Genious" My Soundcloud ---- My Mixcloud
    MBP Retina 2015--TSP 2.10--2xDNSC5000--2xDNSC2900--2xDNSC2000--NI F1--Denon DN-X1700--HDJ2000--Stanton STR8-80--QSC K12's--Crown Amplifier--Urei Monitors

  4. #4
    Tech Guru
    Join Date
    Mar 2012
    Location
    York, UK
    Posts
    3,428

    Default

    Expresscard USB sockets do not provide the same amount of power as regular ports so that might be the cause. USB3 is also a possibility.
    VCM100 / X1 / DJM250 / DJM900 / CDJ2000s / Maschine / Audio2+4 / 2i4 / HS8s / TSP 2.6.8
    Macbook Air i7-3667U+8GB 10.9 / Win7x64 i5-3570k+24GB


  5. #5
    Tech Convert
    Join Date
    Apr 2011
    Posts
    15

    Default

    Thanks for the replies... looks like I'm kinda screwed. Maybe I can find someone to trade me for usb 2.0 model

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •