Last-ditch effort to get S4 communicating AT ALL with PC's
Results 1 to 6 of 6
  1. #1

    Default SOLVED!!! - Last-ditch effort to get S4 communicating AT ALL with PC's

    I bought a used Traktor Kontrol S4 and I have never been able to get a PC computer to "SEE" it (I've tried 3 different PC's). I will save y'all the drama of all the things I've tried from the many articles I've read about this.

    In short, I have what is apparently a common S4 problem... the dreaded blinking USB LED on the S4. Trust me, if a fix has EVER been posted, I've already tried it. So before I take measures against whom I bought it from, I want to ask a simple question:

    When I plug the S4 into a USB 2.0 port, shouldn't SOMETHING change in the Device Manager?

    This is my one and only question! I'm WAY past talking drivers and software.

    The reason I ask this one question is that I have the luxury of having a Kontrol S2 here to do test with. If I plug the S2 into any given PC (without Traktor or any other NI software or drivers), the S2 INSTANTLY COMMUNICATES with the computer and Device Manager has a party going on:
    * Under USB Controllers, a new "USB Composite Device"
    * Under Other Devices it says "Traktor Kontrol S2"
    ... and a balloon pops up from the tray (beside the clock) saying new hardware found and tries (unsuccessfully, of course) to find a driver for it.

    When I plug this S4 into any given PC (all updated Win7), Device Manager doesn't do anything! No balloons, no feedback from the PC in any way shape or form.

    Starting to think S4's USB has been messed up.
    PS - the USB jack is WHITE... I've only seen ORANGE USB jacks on NI controllers.

    Is there such thing as a "hard reset" for these controllers?

    Please, please, please help! Thank you!
    Last edited by Diggin Traktor; 06-14-2013 at 01:50 PM. Reason: Changed Title

  2. #2

    Default

    I noticed you emphasized "PC"; does that mean it works fine on a Mac, or are we talking ANY computer whatsoever here?

    If it's the latter, then my guess would be dry/broken solder connection on the USB socket, or possibly a damaged IC somewhere on the main board.
    For Sale: Handmade Custom DJ Cables - RCA / TRS / XLR!
    Gear: 2x Reloop Contour, Zomo MC-1000, Reloop RMX-40 :: Reloop Terminal Mix 4 :: Korg nanoKONTROL :: Traktor 2.6.1
    Latest Mix: June Progressive House (Soundcloud)

  3. #3
    Tech Guru
    Join Date
    Mar 2012
    Location
    York, UK
    Posts
    3,428

    Default

    Did you install the drivers beforehand on each PC you tried? And do all the S4 lights flash when you plug it in?
    VCM100 / X1 / DJM250 / DJM900 / CDJ2000s / Maschine / Audio2+4 / 2i4 / HS8s / TSP 2.6.8
    Macbook Air i7-3667U+8GB 10.9 / Win7x64 i5-3570k+24GB


  4. #4
    Tech Guru
    Join Date
    Sep 2010
    Location
    Boston/Worcester
    Posts
    1,067

    Default

    USB socket should be orange. Something is goin on there. The orange snap in USB sockets are prone to breaking. You're either looking at a broken USB socket or someone has replaced the USB socket and they failed or even the broken USB socket shorted out and could have possibly done some damage

  5. #5
    Tech Guru
    Join Date
    Nov 2012
    Location
    FL, USA
    Posts
    2,122

    Default

    White is a replaced USB port I'm pretty sure.

    Has the unit been opened? Look and see if there's a hole in the sticker.

  6. #6

    Default

    The suspicions turned out to be the culprit. The S4 always powered up nice and pretty, but I never had ANY confirmation of USB communication. Well, after what y'all said about the suspicious white USB jack (and yes SlrDragon50, there was a hole in the sticker on the back), I decided to get out a Phillips screwdriver to confirm.... Yup, those were definitely not factory solder joints :-(

    All is good though, I'm getting an RMA from the pawn-shop on eBay I bought it from and they seem to have a decent return policy. If I felt better with my soldering skills and equipment, I might have tried to re-solder, but then again I'd probably make it worse.

    Thanks for your replies guys! Y'all really helped!!!!

    Diggin Traktor

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •