Problem with brand new Traktor Audio 10! Computer not reading!
Results 1 to 5 of 5
  1. #1
    Tech Convert
    Join Date
    Dec 2011
    Posts
    12

    Default Problem with brand new Traktor Audio 10! Computer not reading!

    Bought one today, upgraded to traktor scratch pro 2, downloaded all the drivers.. Didnt work.
    So i uninstalled everything. re installed everything. still does not read it.
    ive tried everything. different hubs, different cables.
    It doesnt even light up, only thing thats lights up is the DC/USB light.
    Did i buy a faulty unit?
    Theres ZERO sign of any type of connection between the two and everything is downloaded. idk what to do. about to take it back tomorrow and replace it. Has anyone had this problem before?

  2. #2
    Tech Mentor arsman's Avatar
    Join Date
    May 2013
    Posts
    289

    Default

    did you use both the usb and the power? afak you need to always plug the power cable even when using the usb
    Pizza | Coke | Burger | Fries | Milkshake
    my RGAS story

  3. #3
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,353

    Default

    Don't use USB hubs while installing the unit. Plug it straight to computer and try repeating the installation process.

  4. #4
    Tech Guru lethal_pizzle's Avatar
    Join Date
    Feb 2009
    Location
    Maida Vegas, London
    Posts
    2,816

    Default

    Audio 10 always needs to be plugged into a power socket.
    DJTT Nu Disco Mix Train Vol 1
    beats and balearic bobs in north-west london
    iTunes podcast
    soundcloud

  5. #5
    Tech Convert
    Join Date
    Dec 2011
    Posts
    12

    Default

    turned out it was defective unit, plugged it into a buddies computer and no response, he plugged his a10 in my computer and it worked. Just returned it and got a new one

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •