Got a xone 1d and a few minutes ? Then please try this
Results 1 to 3 of 3
  1. #1
    Tech Guru bumtsch's Avatar
    Join Date
    Sep 2009
    Paris, France

    Default Got a xone 1d and a few minutes ? Then please try this

    Heya all,
    So I got a Xone 1D (new black series) over a month ago. After mapping it I realized the rotaries/jog will often send the wrong midi messages... which can be all kinds of wrong (see here).
    I managed to have it exchanged but the replacement has the same issue.
    If you have the problem, it's pretty easy to reproduce, and you would probably have noticed by now.
    MIDIOX on windows

    Can someone here with a 1D (especially from the new black series) give it a shot please ?

    I'm gonna write back to A&H and my distributor but I'm afraid they might not be as comprehensive as the first time so... just checking.

    I really hope I'm just unlucky and that the whole new series isn't crippled like this...

    ---Moar details!---
    Tried using map1/map2 and different midi channels.
    Tried with a different cable.
    Tried with my usb midimate, powering the 1D off the other pc's USB ports.
    Tried on the other pc (running xp) with the same combinations, with and without the driver.
    With the replacement, I also reproduced it with a new, gold plated, dual-ferrite equipped, usb2 cable *and* booting under linux, so I'm pretty sure it's not the driver.

    Couldn't test on a mac but I'm pretty sure I'd see the same thing and that the 1D itself is buggered.

    Someone else here had this issue once, I tried to bump but no feedback from him so I assume he got a working unit since then.
    He also posted on A&H's forums, but he was the only one.

    When I contacted them, A&H's tech support suggested a crosstalk issue. No kidding!
    Last edited by bumtsch; 10-05-2009 at 01:44 PM.

  2. #2
    Tech Wizard
    Join Date
    Sep 2009


    I was thinking about buying me 2x Xone1D with the Xone 92 mixer, would you say this is a serious problem or?

  3. #3
    Tech Guru bumtsch's Avatar
    Join Date
    Sep 2009
    Paris, France


    I don't think the whole series has this or I'd have seen more reports of this bug happening.

    If you do have the problem and depending on what controls you've mapped, it can be serious.
    You can sorta work around this but basically each control should only send whatever message/s it is supposed to, like everything else on the unit does :P

    For instance I've got the top rotaries assigned to loop size for each deck; jog wheel for track search and extra rotary for fine tempo changes.
    Imagine after setting DECK A's loop size, you want to change it on anothert deck - but instead it'll change it on A and kick you out of time (like switching to 3 beats).
    Or maybe "alright I'm happy with this, let's pick a new track", turn the jogwheel and boom the loop you just set right before changes instead.

    It's like typing a word with your keyboard and finding the last but one letter appears instead of the last letter even though you pressed the right key.

    edit:The two threads reporting this on A&H's forum: (this is a repost from Yosh on DJTT, see my first thread).
    Last edited by bumtsch; 10-06-2009 at 01:33 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts