DJM 900 Nexus & Traktor set up
Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2014

    Default DJM 900 Nexus & Traktor set up

    Hey guys, some assistance required.

    I'm trying to set up Traktor Scratch 2 with a DJM Nexus 900 using a USB straight from the mixer to my mackbook. I've installed all the drivers I can get music playing through the mixer but not with the timecode CD's which I really want, for some reason I can not get the following to show in traktor settings

    Screen Shot 2014-01-15 at 3.19.15 pm.jpg

    I only see this

    Screen Shot 2014-01-15 at 3.09.03 pm.jpg

    Any ideas where i'm going wrong ?

  2. #2
    Tech Guru ImNotDedYet's Avatar
    Join Date
    Jul 2013
    Denver, CO


    You've got the 900 configured as the audio on the audio settings right? You've set it to mix externally?

    I know on my PC, I need to do those two things, but I also have a 900 Nexus Setup Utility that pops up when I plug in the USB. Don't know if Macs are similar. If so, you'll have to make sure that the input and output settings on that setup utility are all correct, then Traktor will automatically populate the input and output settings when the DJM 900 is selected on the audio settings page.

  3. #3
    Tech Guru
    Join Date
    Mar 2012
    York, UK


    The naming of inputs should not affect your ability to use them. Open the DJM Utility program and set the "Mixer Output" channels to the correct timecode input, depending on how your CDJs are connected to the mixer.

    More detailed information is available on page 10 of the DJM 900 user manual.

    Also if you want to attach large screenshots, try using a decent image hosting site so that they can be seen in full resolution.
    VCM100 / X1 / DJM250 / DJM900 / CDJ2000s / Maschine / Audio2+4 / 2i4 / HS8s / TSP 2.6.8
    Macbook Air i7-3667U+8GB 10.9 / Win7x64 i5-3570k+24GB

  4. #4
    Join Date
    Jan 2014

    Default Help!

    Please help! I have 2X CDJ2000 connected to traktor, they work fine.when I plug in my DJM900 NXS the setting utilities shows up.when i go into traktor it will show DJM 900 in the audio setup, but nothing in the input or output routing. I am using traktor Pro 2 v.5.6.5 which is the latest. what am I doing wrong? Or Do I have to be using tractor "SCRATCH" pro?! Thanks in advance!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts