I'm facing an issue installing my VCI-100 to my new computer (WIN7 based).

As I plug the device, it is detected as Unknown Device but a driver is installed and the VCI appears as unknown device in the device manager BUT as USB BUS controller. No exclamation point marked, it is like a working peripheric.

Once it is declared as USB BUS controller, even forcing the driver installation in the device property options will not give me the possibility to set it as Generic Audio device. Only the HUB drivers are made available...

The VCI itself is working, the Data Send LED is reacting to actions but since the device type is wrongly set in windows, the MIDI informations are not treated.

My Traktor (set to work with a VCI) for example does not react since the MIDI infos do not go throw the right drivers.

I searched a lot and did not find similar issues, in most of the case the VCI is not recongnize but at least not set as USB controller. It is always possible to change manually.

I tried several USB ports, changed the USB power setup, tried multiple install / deinstall of the device but it always get this USB controller identification.

Please help!!