Midi Fighter Twister - Issue / Wrong Off LED Color with multiple banks - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Newbie
    Join Date
    Nov 2022
    Posts
    2

    Default

    Quote Originally Posted by Stewe View Post
    Wait a two more weeks it is work in progress.
    Hi Stewe, was this error ever fixed?

  2. #12
    Newbie
    Join Date
    Jan 2023
    Posts
    2

    Default same problem

    Quote Originally Posted by dodebum View Post
    Hi Stewe, was this error ever fixed?
    Just got my MF twister and i'm having the same issue. Encoders continue to send bank 1 CC#s 0-15 and encoder values while on other banks. The only thing changing are the encoder colors.

  3. #13
    Newbie
    Join Date
    Jan 2023
    Posts
    2

    Default

    Hm ok I re-loaded the factory firmware and that seemed to get banks working again.
    Hopefully the problem won't happen again!

  4. #14
    Newbie
    Join Date
    Feb 2023
    Posts
    1

    Default Solved !

    Quote Originally Posted by robreich View Post
    Hm ok I re-loaded the factory firmware and that seemed to get banks working again.
    Hopefully the problem won't happen again!
    Yes, this is it ! I just got a Midifighter twister and was having this same problem. By opening the Midifighter Utility, you can go to Tools > Midifigther > Load factory firmware and pick the first one: Midi Fighter Twister (2 Oct 2019). Apparently the 2, 3 and 4 just change the name of the device (for use when you have multiple twisters)

  5. #15
    Newbie
    Join Date
    Mar 2023
    Posts
    2

    Default

    Quote Originally Posted by lau1159 View Post
    Yes, this is it ! I just got a Midifighter twister and was having this same problem. By opening the Midifighter Utility, you can go to Tools > Midifigther > Load factory firmware and pick the first one: Midi Fighter Twister (2 Oct 2019). Apparently the 2, 3 and 4 just change the name of the device (for use when you have multiple twisters)
    I too had the same problem with firmware 02Oct2019 . Reloading the same firmware 02Oct2019 solved the problem! Hopefully forever!

  6. #16
    Tech Guru the_bastet's Avatar
    Join Date
    May 2012
    Location
    Cincinnati, OH
    Posts
    2,866

    Default

    Quote Originally Posted by dodebum View Post
    Ok so here I am in 2022 with a new Midi Twister eager to use with several banks of beautiful colors. And I get this problem immediately and finds this thread... didn't look it up before I bought it.

    Bank 2-4 shows up with the right color but when I press the knobs they switch to Bank 1 colors and never gets back..

    Was this ever solved? Still no fix for this anywhere? Newest firmware 2019. Did I miss anything else of importance regarding DJ Techtools, updates, firmware, and the Midi Twister?

    I am on a Macbook pro M1 2021.

    (edit: typo)
    One of the many issues I hadf with the brand new twister I got yesterday. Per Stevan, they don't currentlyt have a developer working on the project, so no fixes are coming unfortunately. Sucks cause the 3D was such a solid piece of kit. :-(
    - Equipment - 2X Technics 1200, 2X Audio Technica ATLP1240, 2X XDJ700, 2X XDJ1000 MK2, Denon DNX-1100, Mixars DUO, DJM750 MK2, NI Audio 10, NI Aduio 4, Serato SL3, 4X Shure M44-7, 2X Ortofon Pro S, 2X Numark Groove Tool, Maschine MK3, Samson Carbon 49, Roland SE-02, Novation Launchcontrol, TouchOSC, Nocation Peak, Arturia MiniBrute, Korg Volca Kick, MicroKorg (Classic), NI Komplete Audio 6

  7. #17
    Newbie
    Join Date
    May 2023
    Posts
    1

    Default disappointed

    Just got my Twister. Shipping was very fast, but very disappointed by the firmware. Basically, banks don't work -- all banks revert to bank 1's off color when switch pressed, and while encoder settings for banks 2-4 appear to be saved to the device, the device uses bank 1 settings always.

    Best to treat banks as if they do not exist. This seems like a pretty big problem, given the website and the manual assume it works. Is a 1-bank Twister worth what they charge? Maybe? Depends. Missing firmware features don't detract from the quality of the knobs and chassis.

    Blame the pandemic, blame whatever, my guess is that the company is basically walking dead. They have a bunch of units from a production run that they sell but don't have the capital to hire a contractor or do much new development, update the website, or anything. I can sympathize. But when I realized the state of things reading this thread, it still really left a bad taste. I'm still on the fence as to whether to keep or return mine.

    There aren't a lot of other options: Intech EN16? Faderfox? Shik? Akai? Arturia? None of them great. Maybe the Intech comes closest, but they're another small startup, who knows how long they'll be around or what issues their product has?

  8. #18
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,490

    Default

    Quote Originally Posted by agrover View Post
    Just got my Twister. Shipping was very fast, but very disappointed by the firmware. Basically, banks don't work -- all banks revert to bank 1's off color when switch pressed, and while encoder settings for banks 2-4 appear to be saved to the device, the device uses bank 1 settings always.

    Best to treat banks as if they do not exist. This seems like a pretty big problem, given the website and the manual assume it works. Is a 1-bank Twister worth what they charge? Maybe? Depends. Missing firmware features don't detract from the quality of the knobs and chassis.

    Blame the pandemic, blame whatever, my guess is that the company is basically walking dead. They have a bunch of units from a production run that they sell but don't have the capital to hire a contractor or do much new development, update the website, or anything. I can sympathize. But when I realized the state of things reading this thread, it still really left a bad taste. I'm still on the fence as to whether to keep or return mine.

    There aren't a lot of other options: Intech EN16? Faderfox? Shik? Akai? Arturia? None of them great. Maybe the Intech comes closest, but they're another small startup, who knows how long they'll be around or what issues their product has?
    Hey Agrover,

    Could you please see the following support article and verify that reloading the firmware fixes the bank issue? Thank you.

    https://techtools.zendesk.com/hc/en-...-messages-only

    We are currently seeking for a programmer who can help with updating the midifighter line. That is why you are not seeing any development.

    https://djtechtools.com/wanted-softw...re-programmer/

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •