I have reached the end of the internet searching for a possible hint on my problem with my VCI-100.
Since Vestax isn't existing anymore I thought this would be the best place to find someone with knowledge about the device.

The current situation is like this: I connect any USB cable from any USB socket (also tried powered USB hub) to the VCI and switch it on to USB mode. In Windows the device is not recognized on any PC or laptop; a tool-tip pops up saying USB device not recognized.

The only thing what happens is the power led will switch on but no other sign of life, no other LED lights up.
I have tried then to power it up with an external power supply - the same situation.

One thing I did in the past was the firmware update to 1.4. But since then I used the controller for years without problems. The last time I used it was maybe 1 year ago, since then I had no time for mixing. It worked without problems that time. So this problem came up from nowhere.

Taking a look inside the device and sight check of the electrical components didn't show any suspicious burned components.

I already saw there are some people in the forum with a similar problem like the "USB device not recognized" so I hope maybe could help me in this case.

Looking forward for any support on this.