Midi Fighter looping problem with Utility
Results 1 to 2 of 2
  1. #1
    Newbie
    Join Date
    Jan 2018
    Posts
    2

    Default Midi Fighter looping problem with Utility

    Hello!

    I just recently got my midi fighter twister but I keep getting problems with the utility. Problem is that when I connect the Twister , the screen tells me "Connect a midi fighter twister" and suddenly , the screen changes to the editor mode but then it quickly returns to the "connect the midi fighter twister" and it keeps doing that again and again , like a loop...

    Ive tried to install other versions of the utility and it is the same. Ive also tried to connect the twister into a direct usb port and also by HUB and nothing...

    Im using windows 10 on a PC and also I have a Novation lunchcontrol and an AKAI APC40 connected at the same time , could that be the problem?...

    I would appreciate your help! Thanks!

  2. #2
    DJTT Mapping Ninja Moderator Stewe's Avatar
    Join Date
    Aug 2010
    Location
    MIDI
    Posts
    7,354

    Default

    Happen to me once after updating the firmware. Did you try to uninstall the driver and than plug TW back in to a PC?

    Also, when plugging in Twister for the first time, be sure not to use USB sockets on your case front because those are basically an USB HUB's in 90% of cases. Instead connect it directly in to USB socket on your motherboard and let the software to install.

    Also have you tried different PC?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •