DJM 250mkII Drivers not compatable with Mac OS version 10.14.06
Results 1 to 5 of 5
  1. #1
    Tech Mentor A$H's Avatar
    Join Date
    Oct 2011
    Posts
    316

    Default DJM 250mkII Drivers not compatable with Mac OS version 10.14.06

    I've finaly gotten around to re-installing the firmware for my DJM250mkII and the drivers for my Mac as suggested as a in a thread on a pioneer form.

    But now I can't re-install the driver as the installer says that it's not compatable with MacOS version 10.14.06.

    I was happy to using my DJM 250mkII with Traktor, but I've been itching to use RekordBox for a while and now I can't use either due to the lack of drivers available. Does anyone know of a fix or a way to get the driver to install.

    Screenshot 2019-10-26 at 19.05.44-cleaned.jpg

  2. #2

  3. #3
    Tech Mentor A$H's Avatar
    Join Date
    Oct 2011
    Posts
    316

    Default

    Thank you ErikMinekus.
    Can you link me to the page where you linked downloaded, I feel silly for not spotting this.

  4. #4

    Default

    The page itself is a bit vague, which is why I linked to the 2.0.0 drivers directly.

    https://www.pioneerdj.com/en/support...50mk2/#drivers
    It's the second one, "DRIVER FOR MAC EL CAPITAN OR LATER".

    Rekordbox also comes with all the drivers in /Applications/rekordbox 5/drivers.

  5. #5
    Tech Mentor A$H's Avatar
    Join Date
    Oct 2011
    Posts
    316

    Default

    Quote Originally Posted by ErikMinekus View Post
    The page itself is a bit vague
    That's a massive understatement

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •