Results 1 to 3 of 3
  1. #1
    Tech Convert
    Join Date
    Jul 2011
    Location
    Brisbane Australia
    Posts
    12

    Question Midifighter Classic Bricked?

    I'm having some dramas with my midifighter classic. I've just just bought a mf3d and I've updated the firmware for both devices through the new utility, both were working fine for a while, but now the classic has bricked itself somehow.

    It won't send midi anymore and the utility won't recognize it anymore but it still comes up as online in audio midi setup on my MacBook as well as coming up as a midi out port in traktor. I've tried flashing it with new firmware, as well as flashing it with old firmware and then bringing it back up to date but once it gets back to the current firmware the problem persists.

    I'm also getting the failed to release USB messages when the firmware updater gets to the cleaning stage, which I'm lead to believe isn't a problem, but from what I've read that should have been fixed with the latest update.

    Any help anyone could lend me here would be much appreciated


    Cheers

  2. #2

    Default

    It seems that this is a known problem with the Midi fighter classic Have you tried these reset rules yet?

  3. #3
    DJTT Super Moderator midifidler's Avatar
    Join Date
    Mar 2008
    Location
    San Francisco
    Posts
    1,929

    Default

    Hey Str80180,

    When the classic is connected what LEDs light up? Do LEDs react to button presses?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •